3

In updating a plugin for Craft 3, at one point I also renamed it, and at various times did things in the wrong order. At this point, Craft shows the old, unwanted plugin, but

  • it is not in composer.json
  • it is not in the craft_plugins table
  • none of its tables are in the database
  • its files have been deleted from craft/vendor/ns/plugin

On the CP Plugins page, if I click Remove, composer updates and says it is successfully removed, but it still shows up under plugins.

How does Craft still know of its existence? Do I need to put it back into composer to do a composer remove?

  • If it's not in composer.json, it may still be in composer.lock. Try running composer update to make them match. – Lindsey D May 10 '18 at 16:04
  • Thank you Lindsey. I did that, then tried to remove again. Same results. It acts like it's removing, but the plugin still shows up. – kr37 May 10 '18 at 16:55
  • 1
    Weird... if you nuke your vendor and composer.lock and run composer update from the command line does that help? – Brad Bell May 10 '18 at 18:24
  • Have you tried clearing / removing the cache? – RvdB May 11 '18 at 9:49
  • Which cache? I've certainly done Clear Caches from the CP, but I don't think that's what you mean? – kr37 May 12 '18 at 6:34
6

Although I'm not in favor of the nuclear option in international politics, it works very fine and simply this case. Brad's suggestion of deleting the craft/vendor folder and composer.lock and then running
composer update
solved the problem immediately. Now I appreciate composer.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.