1

I am running on the latest version of Craft (Craft CMS 2.6.3015). I have a blog entry, which has a Rich Text editor for the body field.

However, I do not have an image or file upload field in the WYSIWYG editor, please see the screenshot below.

enter image description here

I have tried adding "image" to the array in /craft/config/redactor/Standard.json but it has no effect.

I have checked the storage folder and all folders have correct permissions.

Where is the button and how can I add it?

1

The simplest method would be to change your Redactor Config to Default in the rich text field settings. Should look something like this:

enter image description here

| improve this answer | |
  • This is already set to Default. I've tried changing to something else and changing back to no avail. – mikemike Apr 27 '18 at 15:12
1

I needed to create an asset source in order to use the image upload functionality. Once an asset source was created the button displayed.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.