I'm having a strange problem on a recent craft install. The plugin store doesn't load, and only reports "Page not found".

  • I've tried another craft install on the same system, and it's working fine.
  • I tried replacing all core craft files with freshly downloaded 3.0.2 files.
  • I've cleared caches, ran updates, loosened all permissions to 777 and everything in between.
  • I've tried two different browsers with cache cleared.
  • I have only 2 plugins installed: Redactor and Position Fieldtype — but I have those on another install as well and that install is fine.
  • The logs in /storage/logs don't show any errors. I tail them, and nothing is reported.

Aside from the plugin page, all other craft systems work. Even the backups can run and save locally.

Is there anything else I can try to either diagnose or solve? Feel like I've hit a wall. Any advice is appreciated.


Solved. There is a bug. When the setting:

omitScriptNameInUrls' => false,

is set to "false" in


The Plugin Store doesn't load. Switching that setting to true will fix it.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.