1

I am currently developing my first website using Craft 3 and I'm loving it overall. I seem to have a small issue that I can't quite figure out. When I go to the updates section in the admin panel, I am proposed multiple updates to Craft and 2 of my plugins (see screenshot). However, I can't figure out how to actually do these updates! According to this page in the docs, a button should appear at the top of the page.

I've also tried via composer : composer update craftcms/craft, but it says 'Package "craftcms/craft" listed for update is not installed'.

And I've tried : composer update craftcms/cms and that gives 'Nothing to install or update'. Same thing if I try to update plugins such as redactor that way.

enter image description here

I had started out on RC14 and I was able to update to RC15 properly via the button, but since then, the button no longer shows. Since I am new to Craft, I am not sure which log would contain pertinent information for the problem. I will be glad to share some logs if necessary. If it changes anything, I purchased a Pro license before the license changes on Apr 04.

Sorry if this is a noob question, any help is appreciated!

  • First things first: did you by any chance add or change the allowUpdates config setting, as mentioned on docs.craftcms.com/api/v3/…? – Paul Apr 12 '18 at 18:47
  • Can you also post what your composer.json looks like for this project? Just the line that has craftcms/cms in it is needed. – andrew.welch Apr 12 '18 at 18:47
  • That was my next comment, @andrew.welch ;) – Paul Apr 12 '18 at 18:49
  • Wow I can't believe it was the allowUpdates setting was set to false. I must have changed it at some point and didn't remember. Looking at the config file again, it says "Don't allow auto updates" as a comment above that setting. I must have set it to false thinking that if it was set to true, Craft would automatically update without asking, which I didn't want to happen. I didn't think it would entirely prevent Craft from allowing updates. Maybe that comment coule be clearer? Just a thought. Thanks a lot for the help guys! – Rhys Halsey Apr 12 '18 at 21:48
3

As a silly mistake, I had set the allowUpdates config setting to false...hope this helps anyone making the same silly mistake.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.