1

Folks:

The client receives an email with order details that include the customer shipping address. On a couple of occasions, though, the shipping details do not show. Notes:

  • The email is delivered without an issue.
  • The customer shipping address is missing.
  • The customer email still makes it through. Not sure why just the email comes through but could be a fluke.
  • The order form does not allow the user to complete the transaction without a shipping address.
  • Neither the commerce nor the craft log files show anything amiss.
  • Viewing the confirmation email source reveals nothing.

The customer confirmed that they entered all their details. The customer also confirmed that they are using standard Chrome and that they checked all their details before placing the order. They also attempted the same transaction a second time at the request of the client and they could not get past the address screen without entering a shipping address.

Any assistance would be appreciated.

  • Are you setting the config variables: – Luke Holder Apr 4 '18 at 15:12
1

Are you setting the requireShippingAddressAtCheckout and requireShippingMethodSelectionAtCheckout config variables to true?

https://craftcommerce.com/docs/configuration#requireshippingaddressatcheckout

| improve this answer | |
  • I made this change and the problem seems to be resolved. This site has had thousands of transactions since launch so I'm not sure why a few of these started showing up in the last month. Hopefully this fix sticks. – Wonko Apr 18 '18 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.