1

I tried following the installation instructions here: https://docs.craftcms.com/commerce/v2/installation.html

When I run composer install craftcms/commerce, it says:

Invalid argument craftcms/commerce. Use "composer require craftcms/commerce" instead to add packages to your composer.json.

So I then ran composer require craftcms/commerce, and it says:

[InvalidArgumentException] Could not find package craftcms/commerce at any version for your minimum-stability (alpha). Check the package spelling or your mini mum-stability

I have added "craftcms/commerce":"@alpha" in the require field in composer.json also changed minimum stability to alpha ("minimum-stability": "alpha").

But it still is not working. Any thoughts? Thanks!

2

You have to contact P&T (at support@craftcms.com) directly to get installation instructions.

1

As far as I know, there are no public releases of Commerce 2 (for Craft 3) yet. According to the official launch faq:

When will Commerce 2 be released? We will release Commerce 2 Beta on April 4 alongside Craft 3 GA. If you need access to Commerce 2 beforehand, or you are a plugin developer hoping to get started on a Commerce integration, get in touch for advanced access. We expect the beta will last about three to six months.

Looks like the GitHub repo you linked to is where they're compiling the docs in preparation for April 4th. If you want access to the alpha version or whatever, looks like you should contact Pixel & Tonic for pre-release access.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.