1

Yesterday, things worked fine with SproutSeo 2. I replaced two images for default pages in that plugin.

Today, some entries aren't picking up images correctly.

Some sections have

meta property='og:image' -- Still maps to the correct content image

meta property='og:image:secure_url' is also showing, but this does not map to the image. Instead, it maps to the default image for that section (ie not for the particular post, but for the index in that section) and in others, it maps to an image that is NOT the default image.

I have the craft template set to pick up the default image or to place in a featured image. This is done as in this example: https://sprout.barrelstrengthdesign.com/craft-plugins/seo/docs/sprout-seo-2/overriding-images

So I have an override for ogImage. The problem is that I don't know a way to set the og:image:secure_url property. (I can't say I've ever noticed this property before today) I can't find an override to use within the template. I don't see a setting in the SproutSEO panel.

How can I override og:image:secure_url or make it go away or whatever else I need to do so that the correct images get matched? (Ideally before I LMS over this hiccup)

3
  • Can you try overriding: ogImageSecure? – Ben Parizek Mar 13 '18 at 19:24
  • Sure I can...if it exists (I hope you are not teasing me). It doesn't show in the documentation I can find. – esspbee Mar 13 '18 at 19:28
  • It exists. I'm not sure it addresses the root of your issue, as the behavior you describe does sound odd, but it may help solve things for now. I've added this to our list to look into further. – Ben Parizek Mar 13 '18 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.