1

I've been running an installation Craft CMS 3.0.0-RC13 for some time with no problems. However, now I cannot install new plugins nor can I remove any that are currently installed. I keep getting the same (or similar) error. The full response is included below.

I've tried

composer remove [package]

composer clear-cache

composer update 

Almost seems like Composer has been corrupted or something. I'm assuming that the information about "php version does not satisfy..." is related to the bad package because I didn't alter anything about my php configuration.

Screenshot of the persistent error message

Composer was unable to install the updates.

Error: An error occurred

Output: Loading composer repositories with package information Updating dependencies Your requirements could not be resolved to an installable set of packages.

Problem 1 - The requested package am-impact/amnav could not be found in any version, there may be a typo in the package name. Problem 2 - symfony/intl v3.3.7 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.27-1~dotdeb+8.1) overridden by "config.platform.php" version (7.0) does not satisfy that requirement. - symfony/intl v3.3.8 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.27-1~dotdeb+8.1) overridden by "config.platform.php" version (7.0) does not satisfy that requirement. - symfony/intl v3.3.9 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.27-1~dotdeb+8.1) overridden by "config.platform.php" version (7.0) does not satisfy that requirement. - symfony/intl v3.4.0 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.27-1~dotdeb+8.1) overridden by "config.platform.php" version (7.0) does not satisfy that requirement. - symfony/intl v3.3.10 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.27-1~dotdeb+8.1) overridden by "config.platform.php" version (7.0) does not satisfy that requirement. - symfony/intl v3.3.11 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.27-1~dotdeb+8.1) overridden by "config.platform.php" version (7.0) does not satisfy that requirement. - symfony/intl v3.3.12 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.27-1~dotdeb+8.1) overridden by "config.platform.php" version (7.0) does not satisfy that requirement. - symfony/intl v3.3.13 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.27-1~dotdeb+8.1) overridden by "config.platform.php" version (7.0) does not satisfy that requirement. - symfony/intl v3.3.14 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.27-1~dotdeb+8.1) overridden by "config.platform.php" version (7.0) does not satisfy that requirement. - symfony/intl v3.4.1 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.27-1~dotdeb+8.1) overridden by "config.platform.php" version (7.0) does not satisfy that requirement. - symfony/intl v3.4.2 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.27-1~dotdeb+8.1) overridden by "config.platform.php" version (7.0) does not satisfy that requirement. - symfony/intl v3.4.3 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.27-1~dotdeb+8.1) overridden by "config.platform.php" version (7.0) does not satisfy that requirement. - symfony/intl v3.3.15 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.27-1~dotdeb+8.1) overridden by "config.platform.php" version (7.0) does not satisfy that requirement. - symfony/intl v3.4.4 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.27-1~dotdeb+8.1) overridden by "config.platform.php" version (7.0) does not satisfy that requirement. - symfony/intl v3.3.16 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.27-1~dotdeb+8.1) overridden by "config.platform.php" version (7.0) does not satisfy that requirement. - symfony/intl v3.4.5 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.27-1~dotdeb+8.1) overridden by "config.platform.php" version (7.0) does not satisfy that requirement. - Installation request for roave/security-advisories dev-master#3df94834c80037130b533703df4672785b6ea112 -> satisfiable by roave/security-advisories[dev-master]. - newism/craft3-fields 0.0.10 requires symfony/intl ^3.3 -> satisfiable by symfony/intl[v3.4.5, v3.3.16, v3.4.4, v3.3.15, v3.4.3, v3.4.2, v3.4.1, v3.3.14, v3.3.13, v3.3.12, v3.3.11, v3.3.10, v3.4.0, v3.3.9, v3.3.8, v3.3.7, v3.3.6, v3.3.5, v3.3.4, v3.3.3, v3.3.2, v3.3.1, v3.3.0]. - symfony/intl v3.3.6 conflicts with roave/security-advisories[dev-master]. - symfony/intl v3.3.5 conflicts with roave/security-advisories[dev-master]. - symfony/intl v3.3.4 conflicts with roave/security-advisories[dev-master]. - symfony/intl v3.3.3 conflicts with roave/security-advisories[dev-master]. - symfony/intl v3.3.2 conflicts with roave/security-advisories[dev-master]. - symfony/intl v3.3.1 conflicts with roave/security-advisories[dev-master]. - symfony/intl v3.3.0 conflicts with roave/security-advisories[dev-master]. - Installation request for newism/craft3-fields ^0.0.10 -> satisfiable by newism/craft3-fields[0.0.10].

Potential causes: - A typo in the package name - The package is not available in a stable-enough version according to your minimum-stability setting see for more details. - It's a private package and you forgot to add a custom repository to find it

Read for further common problems. Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.

1

Problem 1 - The requested package am-impact/amnav could not be found in any version, there may be a typo in the package name.

am-impact/amnav isn't a valid Craft 3 plugin, so you need to move that reference from yourcomposer.json` file. You can see the full list of Craft 3 plugins here: https://plugins.craftcms.com/

symfony/intl v3.3.7 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.27-1~dotdeb+8.1)...

All of those usually happen when you run a composer update/install on environment A that has higher library versions than environment B and you deploy the composer.lock file to environment B and try to run composer update again.

You can force Composer to use a "lowest common denominator" across all environments like so: https://github.com/pixelandtonic/craftcom/blob/develop/composer.json#L31-L33

Installation request for roave/security-advisories dev-master#3df94834c80037130b533703df4672785b6ea112 -> satisfiable by roave/security-advisories[dev-master]. - newism/craft3-fields 0.0.10 requires symfony/intl ^3.3

You can either remove roave/security-advisories from your composer.json file, remove newism/craft3-fields from it or wait for the author of the craft3-fields plugin to bump their symfony dependencies to a higher version that doesn't trigger roave/security-advisories.

Note that after making changes to your composer.json, you'll need to run composer update from terminal from your project's root.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.