9

I am receiving the following error when I click on Check for Updates ...

Craft is unable to determine if an update is available at this time.

Do you know what could be causing this?

  • 3
    Technically, this question was a result of a system configuration error for the OP. But, Brad's answer is an excellent explanation of why that message would occur, and what should be done when it happens. Since the OP was kind enough to mark Brad's answer as the correct one, we should leave this question open for historical purposes. I've tweaked the original question to be a bit more generic. – Lindsey D Sep 4 '14 at 18:52
12

You'll get this if (for any reason) your local install can't connect to our web service that holds all of our update and release information.

If this happens, your local install will cache that there was a connection error and cache to not try again for 5 minutes, no matter how many times you refresh.

So you can either wait the 5 minutes and try again, or clear your data caches under Settings->Tools->Clear Caches Tool and try again and hopefully the connection problem will have resolved itself.

You can also check your craft/storage/runtime/logs files for any cURL related errors indicating a cURL configuration problem on the box.

  • 1
    I cleared the cache to no avail. After combing through error logs, I found I had an error with my curl and ssl setup via homebrew. After re-installing those items and reinstalling php55 like so... brew install php55 --with-homebrew-curl --with-homebrew-libxslt --with-homebrew-openssl --without-snmp everything seemed to be fixed and was able to run my updates – BrianZ Sep 4 '14 at 17:41
  • Ahh... well, there is the log files, too. Nice catch. :) – Brad Bell Sep 4 '14 at 17:43
  • Please also keep in mind that php56 does not work. – Lars Bilke Nov 3 '14 at 11:56
  • 1
    @SteveMock Check your craft/storage/runtime/logs files for cURL related errors. – Brad Bell Dec 7 '16 at 22:51
  • 1
    Done. @BradBell In the meantime: resolved. See my answer. – Steve Mock Dec 8 '16 at 14:19
4

I cleared the cache to no avail. After combing through error logs, I found I had an error with my curl and ssl setup via homebrew. After re-installing those items and reinstalling php55 like so...

brew install php55 --with-homebrew-curl --with-homebrew-libxslt --with-homebrew-openssl --without-snmp

...everything seemed to be fixed and was able to run my updates.

1

I had this problem because my VPN was interfering with local cURL requests. I disabled the VPN and Craft was able to detect updates. I'm working with my VPN provider now to figure out a permanent solution.

0

Check your craft/config/license.key

Ours got out of sync with a remote repo and contained unresolved conflict.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.