1

We have multiple people working on a craft site using Vagrant and Virtual Box for our local server.

I am running MacOS Sierra, and everything works as expected. A couple of our other developers have updated to run High Sierra, and when they would pull down the git repo for the project this error shows up:

include(/vagrant/app/craft/app/vendor/composer/../twig/twig/lib/Twig/Source.php): failed to open stream: No such file or directory

This happens when Vagrant is up and running successfully, gulp is watching, and all the user is trying to do is connect to localhost:3000 through their browser. These computers had successfully worked on the project in the past before updating their OS.

We tried doing a fresh pull down of the repo on a computer that had never worked on the project (but also using High Sierra) and we get the same exact error. So the only thing we know that is different between my computer (which works as expected) and the others is that mine is running Sierra and the others are running High Sierra.

We've tried searching online for this issue, but haven't found anybody posting similar enough problems. Also, I am posting this here since it is a Craft CMS project, so if I should switch this to a different stack exchange, let me know. Thank you!

SETUP INFO:

config.vm.box = "ubuntu/trusty32"
config.vm.box_url = "https://vagrantcloud.com/ubuntu/boxes/trusty32"

Tools: Vagrant, Virtual Box, Gulp, rsync installed through homebrew

Let me know if there is anything specific about our setup that you'll need to see to be more helpful.

1

It sounds like you're running into this recent Composer autoloading bug: https://github.com/composer/composer/issues/6977

Chances are if you composer self-update, the issue will go away.

| improve this answer | |
  • Excellent, ok we'll give this a shot and I'll report back. Thanks! – jkilp Jan 11 '18 at 19:20
  • So, our other developer ran that code, but he is saying that he gets exactly the same error. Is there any other information or screenshots that I can attached that would be helpful in possibly diagnosing what the issue could be? – jkilp Jan 11 '18 at 20:09
  • If they run composer -V, what version are they on? – Brad Bell Jan 11 '18 at 21:09
  • version 1.6.2 2018-01-05 15:28:41 – jkilp Jan 11 '18 at 21:17
  • Well, now I'm out of ideas. :) – Brad Bell Jan 11 '18 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.