1

I have installed composer successfully but when I try to add:

composer require craftcms/plugin-installer

I get the following:

Your requirements could not be resolved to an installable set of packages.

Problem 1
- craftcms/cms 3.0.0-RC4 requires craftcms/plugin-installer ~1.5.0 -> satisfiable by craftcms/plugin-installer[1.5.0, 1.5.1, 1.5.2] but these conflict with your requirements or minimum-stability.
- craftcms/cms 3.0.0-RC4 requires craftcms/plugin-installer ~1.5.0 -> satisfiable by craftcms/plugin-installer[1.5.0, 1.5.1, 1.5.2] but these conflict with your requirements or minimum-stability.
- craftcms/cms 3.0.0-RC4 requires craftcms/plugin-installer ~1.5.0 -> satisfiable by craftcms/plugin-installer[1.5.0, 1.5.1, 1.5.2] but these conflict with your requirements or minimum-stability.
- Installation request for craftcms/cms 3.0.0-RC4 -> satisfiable by craftcms/cms[3.0.0-RC4].

Installation failed, reverting ./composer.json to its original content.

I have also tried the following with no luck:

composer require craftcms/plugin-installer --ignore-platform-regs

Note my composer.json file shows the following:

{

"minimum-stability": "dev",
"repositories": [
    {
        "type": "composer",
        "url": "https://asset-packagist.org"
    }
],
"config": {
    "optimize-autoloader": true,
    "platform":{
        "php":"7.1.1"
    }
},
"require": {
    "craftcms/cms": "3.0.0-RC4"
}
}

Any help would be appreciated! On a side note this is a local install using Mamp Pro.

2
  • Is there a reason you're manually doing composer require craftcms/plugin-installer? craftcms/cms requires it directly and github.com/craftcms/docs/blob/master/en/… pulls it in for you.
    – Brad Bell
    Jan 3 '18 at 2:34
  • Something I unfortunately forgot to mention is that I'm upgrading from Craft 2 to Craft 3. I was following Mijingo's "Upgrade Craft 2 to 3" video and I can't get past the require craftcms/plugin-installer command. Jan 5 '18 at 19:31
2

I had the same problem following that video, i assume the ReleaseCandidate upgrade differs from the beta upgrade. Following the instructions from the craftcms github repo worked for me. https://docs.craftcms.com/v3/upgrade.html

3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.