0

I've added many fields in the past with success but today, on my local MAMP server, after adding a new field to a Matrix and saving, I'm getting a PHP error when I try to view the entry's admin page, the page preview, or try to add a new entry.

Thankfully removing that field and saving gets me back to where I was. The CMS is up to date. Here is the error when trying to view the entry's admin, I can post more if it helps (the stack trace has 70+ errors in it):

PHP error When creating a new entry, the error is also on BaseOptionsFieldType.php but line 362:

if ($option['value'] == $value)

Would anyone have any ideas for getting around this? The field I want to add is a Lightswitch but I get the same error when trying a Plain Text field.

  • A little work around would be to check if the key in this array is set/exists to not get the error. Do you have the latest craft version? – Robin Schambach Dec 13 '17 at 17:06
  • Is it a particularly large Matrix field? How many blocks/fields are in it? – Brad Bell Dec 13 '17 at 23:52
  • Thanks both. Robin I got the error on an older version from a few months ago, but I updated and got more-or-less the same error. Brad, the Matrix field has 12 block types set up, with each of those averaging three fields. Some of those fields use Super Tables and a couple of those have Dropdowns with around 15 options (think I'll rework things there when I get a chance!). You've led me to the solution - I will post it as the answer. – Chris Dec 14 '17 at 9:20
0

I tried removing a few of the options from one of the Dropdowns within the Matrix and lo-and-behold, the errors are gone. Thanks so much! I guess I hit some kind of limit?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.