Craft 3 RC is installed locally. After clicking on the Plugin Store the loading animation stays for 1-3 seconds. After that, the right canvas leaves grey without content.

  • I've checked the XHR request, it seems working.
  • reinstalled Craft with composer
  • tested several browsers

What could be a reason for an empty Plugin Store?


I've tested the issue with a clean install of Craft 3, same problem there. So it should be something global on my machine.

Someone have an idea where the problem could be hidden?

  • Have you tried emptying/deleting your storage folder? Dec 10, 2017 at 15:25
  • Any JavaScript errors in the browser's console?
    – Brad Bell
    Dec 10, 2017 at 17:59
  • @MatsMikkelRummelhoff Yes, no success…
    – Malte
    Dec 13, 2017 at 18:19
  • @BradBell No, unfortunately not.
    – Malte
    Dec 13, 2017 at 18:19
  • The plugin store in the Control Panel is actually a Vue.js app. Maybe you've got something else loaded (rewrites, plugins, etc.) loaded interfering with it's routing?
    – Brad Bell
    Dec 13, 2017 at 23:57

2 Answers 2


I had to download the CA certificate for curl :


And added it to php.ini to get the plugin store working on my local dev env.

curl.cainfo = "x:\path\cacert.pem"

[IIS windows as local dev env]


The current Craft update solved the issue! Now finally I can see the content of the Plugin Store.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.