1

I am uploading a repo that works fine on a staging server to a live server. When doing so however the homepage is showing as "index of \" page with the public and readme.md directories showing. Like so

enter image description here

When i click on the public link it brings me to the page, however it has no public assets or css. it is just HTML.

enter image description here

The database is linked properly. their are no errors that are showing as it is on dev mode. What can I do to fix this?

Here is the file structure in my home directory which is proper.

enter image description here

Thank you for your time.

  • Could you please share how you have managed the index.php and craft folder inside your home directory – hashtagerrors Dec 10 '17 at 9:18
  • I have added a screenshot of the file stucture. – Tony Garand Dec 10 '17 at 9:41
2

I found the problem, I guess it wasn't craft cms related.

I had to update my apache2 site-enabled config file!

1

Ok here is a quick solution to your problem:

  1. Move all your public files to the same directory where your craft folder is.

  2. Change your Craft path in index.php file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.