I keep getting stranded at the "Oops" modal on install. This is on the third Craft site I've started. The other two Craft 2 sites stood up fine, an I've been developing them for nearly a year.

I've seen questions about this but haven't seen a resolution. Maybe my situation will help figure this out.

Log error output:

[error] [exception.CDbException] exception 'CDbException' with message 'CDbCommand failed to execute the SQL statement: SQLSTATE[42S01]: Base table or view already exists: 1050 Table 'craft_entryversions' already exists' in /var/www/thesite/craft/app/framework/db/CDbCommand.php:358

Stack trace:

#0 /var/www/thesite/craft/app/framework/db/CDbCommand.php(1352): CDbCommand->execute()
#1 /var/www/thesite/craft/app/etc/db/DbCommand.php(507): CDbCommand->createTable('craft_entryvers...', Array, NULL)
#2 /var/www/thesite/craft/app/records/BaseRecord.php(301): Craft\DbCommand->createTable('entryversions', Array, NULL, true)
#3 /var/www/thesite/craft/app/services/InstallService.php(172): Craft\BaseRecord->createTable()
#4 /var/www/thesite/craft/app/services/InstallService.php(56): Craft\InstallService->_createTablesFromRecords(Array)
#5 /var/www/thesite/craft/app/controllers/InstallController.php(159): Craft\InstallService->run(Array)
#6 /var/www/thesite/craft/app/framework/web/actions/CInlineAction.php(49): Craft\InstallController->actionInstall()
#7 /var/www/thesite/craft/app/framework/web/CController.php(308): CInlineAction->runWithParams(Array)
#8 /var/www/thesite/craft/app/framework/web/CController.php(286): CController->runAction(Object(CInlineAction))
#9 /var/www/thesite/craft/app/framework/web/CController.php(265): CController->runActionWithFilters(Object(CInlineAction), Array)
#10 /var/www/thesite/craft/app/framework/web/CWebApplication.php(282): CController->run('install')
#11 /var/www/thesite/craft/app/etc/web/WebApp.php(823): CWebApplication->runController('install/install')
#12 /var/www/thesite/craft/app/etc/web/WebApp.php(790): Craft\WebApp->_processActionRequest()
#13 /var/www/thesite/craft/app/etc/web/WebApp.php(203): Craft\WebApp->_processInstallRequest()
#14 /var/www/thesite/craft/app/framework/base/CApplication.php(185): Craft\WebApp->processRequest()
#15 /var/www/thesite/craft/app/index.php(62): CApplication->run()
#16 /var/www/thesite/public/index.php(19): require_once('/var/www/thesite...')
#17 {main}

I've tried this on a couple of local vagrant boxes:

  • ubuntu xenial 64, nginx, php7.0-fpm, mysql server 5.7.20
  • ubutnu trusty 64, nginx, php5-fpm, mysql-server 5.5.58

I have successfully installed an older version of Craft on both of these boxes before.

The DB user was root for both environments, so DB permissions shouldn't be an issue as suggested in another post about this.

I also tried deleting the tables mentioned in the log and tried again, as mentioned in another post about this. I just got an error about another duplicate table.

I also destroyed and recreated each vagrant box, so I don't think lingering sql temp files are an issue as reported elsewhere.

Any new direction on this would be awesome. We already have a Craft site ready for production, but if we can't use it for a related site for the same client, we'll have to move on to something else, and that's the last thing I want to do.

  • Maybe use xDebug and put a breakpoint in Craft's craft/app/controllers/InstallController.php's actionInstall method? Step through and something might come up as to why it appears that EntryVersionRecord.php is getting run twice?
    – Brad Bell
    Commented Dec 1, 2017 at 17:45
  • hi Brad. Thanks for commenting quickly. Good idea. I'll report back.
    – borducks
    Commented Dec 1, 2017 at 17:48

1 Answer 1


This is an indirect answer, but if you don't have time to debug the install process to set up a Vagrant box, grab this:


Something about it doesn't trigger the duplicate table trouble. Someday I'll have time to figure out why.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.