1

Downloaded latest release, pushed app-new to server, renamed app to app-old, renamed app-new to app.

Try to go to admin, and I get a 500 error.

Server error log shows. 2017-11-15 12:29:29 Error 500 GET /admin HTTP/1.1

Any ideas. Trying to update an install that hasn't been updated in a long time. Going from 2.6.2911 to 2.6.2974

I can still get to admin if I use the old app by renaming app to app-new, and app-old to app

  • If it's a Craft-styled 500 Internal Server Error, the underlying message should be in your craft/storage/runtime/logs files. – Brad Bell Nov 15 '17 at 20:35
  • It's not a craft syled 500 error – Bowenac Nov 15 '17 at 20:49
  • If you open your browser's console, go to the network tab, do you get anything back in the response to the request that causes the 500? – Brad Bell Nov 15 '17 at 20:53
  • Just noticed the download from craft site is 2.6.2997 vs the download button on site I'm trying to update gave me 2.6.2974 not sure why that is but will try the one from craft site. – Bowenac Nov 15 '17 at 20:53
  • Ok when I try to update to 2.6.2977 I at least get a message You need to be on at least Craft CMS 2.6.2922 before you can manually update to Craft CMS 2.6.2997. I will try the download again for 2.6.2974 maybe it's corrupt. – Bowenac Nov 15 '17 at 21:08
1

Re-downloaded manual update, and pushed to the server via ftp again fixed the issue. Download might have been corrupt is my only thought.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.