I'm having a really weird issue with user registration. I've got verification turned off, and logging in after activation turned on, so that when a user registers then checks out, it's a seamless flow. And this works. But the login form at /login does not. Whenever I try to create an account I get this in the logs:

$_POST=array (
  'action' => 'users/saveUser',
  'redirect' => '/confirm-account',
  'firstName' => 'Test',
  'lastName' => 'User',
  'email' => 'testuser9181@gmail.com',
  'password' => REDACTED,

$_SESSION=array (
  '8dfc5494412903b44af114111435fc5cYii.CWebUser.flash.error' => 'Invalid username or password.',
  '8dfc5494412903b44af114111435fc5cYii.CWebUser.flashcounters' => 
  array (
    'error' => 0,

Any idea what might be going on here? I have no idea what's causing this, and why it's working on one page and not the other. I can copy/paste the registration code from the checkout page and it will not work at /login. The same template is being extended.

  • Fixed by updating to 2.6.2997 Nov 13 '17 at 19:58
  • It might be a good idea to accept your own answer so the question is marked as "solved" Nov 13 '17 at 20:04
  • I tried, I can't accept my own answer for 2 days. Nov 13 '17 at 20:09

Fixed by upgrading to 2.6.2997.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.