1

I'm not able to login to my local craft cms in google chrome canary, version 63.0.3233.0. I've attached a screenshot of the error message I've received when trying to go to the standard login page. I can log in fine on normal Chrome.

I know Canary is beta software of newer version of chrome, however, if they release this into the wild later on, is it something to worry about? I'm running MAMP free. Is it something that can be fixed with MAMP pro or? Any suggestions most welcome. Thanks :)

enter image description here

1

Context: https://ma.ttias.be/chrome-force-dev-domains-https-via-preloaded-hsts/

The gist is that Chrome is forcing all .dev domains to use https (SSL) via HSTS.

If you want to continue to use a .dev domain, then you'll need to create a valid self-signed SSL cert and make sure OpenSSL is configured properly on your box.

Alternatively, you can swap to using something like craft.test because .test is reserved to never be used as an official top level domain. https://en.wikipedia.org/wiki/.test

1
  • Very interesting indeed. Thanks for your reply Brad. I'll confirm this as answered. Oct 6 '17 at 8:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.