1

I don't have any logs appearing in craft/storage/runtime/logs (in fact I don't have anything at all in craft/storage/runtime. I'm running Craft on Heroku. I've tried setting post-install scripts in the composer.json file to run

chmod -R 774 craft/storage

but it doesn't change the permissions (they remain at 700). We run Papertrail to collect logs from the dynos, but these only seem to include web requests - no application logging. I've tried enabling devMode, but it makes no difference.

I'm trying to debug some issues we have with the application occasionally falling over, but without access to logs it's impossible - is there any way to make Craft start logging? Just logging to stdout would be fine, as Papertrail would collect the logs. I can't find any configuration options, maybe I've missed them?

1

There is a plugin that redirects all of Craft log output to stderr that works on Heroku and Fortrabbit.

https://github.com/ostark/craft-stderr-logger

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.