1

We’re running into issues with the null coalescence operator in the latest version of Craft (2.6.2989).

enter image description here

Does anyone know why this might be happening?

  • Where are getting this error? In the Control Panel somewhere? – Brad Bell Sep 8 '17 at 18:13
  • Also, what version of PHP are you running? – Brad Bell Sep 8 '17 at 18:13
  • That's in the CP. Currently on PHP 7.0.10, however, it's also present on PHP 7.1. – Josh Baker Sep 8 '17 at 19:19
  • 1
    Things to try: 1. Re-download Craft and replace the /app folder. 2. Disable all plugins; if the error goes away; re-enable the plugins one by one. – Mats Mikkel Rummelhoff Sep 8 '17 at 23:54
  • 1
    Sorry, @Mats; You were right! I hadn’t properly disabled all plugins, it seems. Removing plugins via the database one by one did root out the issue. – Josh Baker Sep 11 '17 at 9:15
2

The issue was a plugin’s composer.json that was loading an older version of Twig as a nested dependancy, which was overriding Craft’s Twig.

Running a composer update for that plugin rectified the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.