1

Running into an issue whereby front end asset uploads are not the correct orientation. I've spotted this mostly with user profile pics.

What's the best way to start debugging this?

My server has ImageMagick extension installed. I believe it's happening when a photo is being directly uploaded from a phone/mobile device. (The one time I managed to recreate it was a direct upload of an untouched photo from my iPhone.)

Any help appreciated. Thanks.

  • 1
    You get the same behavior for those images from the CP, I'd guess? Any chance those images just don't have the orientation EXIF data set? craftcms.com/docs/… – Brad Bell Sep 5 '17 at 23:50
  • Same if I try uploading from the CP yes. Just tested with a photo taken directly on my iPhone and it's shows rotated 90 deg. However, if I edit that photo on my phone beforehand (I cropped it) then upload it, the orientation is correct. ?? – shorn Sep 6 '17 at 0:06
  • I ran into this same issue with a project for a client a couple years ago, and I'm almost certain @BradBell second recommendation about EXIF orientation data is correct. Try following the suggestion in the link Brad gave and set rotateImagesOnUploadByExifData to true in your general.php config file. – blendenzo Sep 6 '17 at 16:48
  • 1
    Just managed to test this, added the rotateImagesOnUploadByExifData setting to my config and... still not working :( – shorn Sep 7 '17 at 22:02
  • 1
    Nope, unfortunately not! :( – shorn Oct 24 '17 at 10:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.