0

We uploaded a lot of images to the S3 bucket that is connected to our assets in Craft, but when we run "Update Asset Indexes" on the settings page, those images aren't added to the assets in Craft.

I'm pretty sure that the settings for the asset source is correct (images that we upload via Craft are working). And it doesn't seem to be related to a time-out, because we updated the php and nginx settings, and now it finishes after ~70s instead of 60s.

What are we doing wrong? Is it even possible to import images this way?

  • Anything in your craft/storage/runtime/logs files when you update the asset indexes? If you have your browser's console open when you run it, do you get any non-200 O.K. responses? – Brad Bell Aug 24 '17 at 22:16
  • 1
    @BradBell Thanks for your comment. There was nothing in the craft logs, but the browser did returned a 502. I'm able to lower the timeout through nginx settings, but not increase it. So my current idea is that it's memory related. Maybe trying to import 21000+ images this way is to much. :o I'm thinking that we need to make a plugin to handle this amount of images. – Youniteus Aug 25 '17 at 19:40
  • Just found this related question (craftcms.stackexchange.com/questions/6505/…) with a possible solution through a plugin (github.com/a-digital/assetindexer). – Youniteus Aug 25 '17 at 19:50
  • 1
    Hmm that plugin isn't working to well. We're going to try to tweak with the craft code, and possibly create our own plugin. – Youniteus Aug 27 '17 at 11:23
0

We ended up using this cli tool: https://github.com/rsanchez/craft-cli

We still had to tweak the php memory limit in the php config: memory_limit 2048M

But eventually we managed to index 21.000+ images this way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.