2

I'm running Craft with MAMP under this file system path:

craft/
public_html/
    index.php
    img/uploads/

Via Settings > Assets, I have set the following paths:

Craft CMS Assets Settings

I've also tried this path under "URL":

http://localhost:8888/project_name/craft/public_html/img/uploads/

When I go to upload an image, the loading bar is stuck at 100% and nothing uploads. What am I doing wrong here?

2

Try access your asset by this URL:

http://localhost:8888/img/uploads/
0

It turns out that the problem wasn't down to the asset paths.

After setting the original paths from my question, I was able to upload PNG files, but not JPEGs.

You need to enable ImageMagick in php.ini on MAMP for Craft to accept JPEG uploads.

See this answer for more information.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.