1

I switched from Apache to Nginx. When I did that the Craft folder that was outside of the web root no longer was recognized. Checked around, dug into my .conf files and spent a boatload on this issue, no dice. Thinking it was ownership or folder permissions, but I changed /craft folder to 777, made no difference.

Once I brought back in the Craft directory under public_html it was all good. I would rather it be outside of that. Have any of you run Nginx and Craft together successfully with the folder being under public_html?

  • Were you getting a particular error or message? Did you adjust the $craftPath setting in the public index.php file? – Brad Bell Aug 21 '17 at 22:57
  • No, I kept everything the same $craftPath = '../craft', when I moved the folder I changed it to $craftPath = './craft'. Error: Could not find your craft/ folder. Please ensure that $craftPath is set correctly – Vin Aug 22 '17 at 0:04
1

I further adjusted permissions on the folders again and made a copy (everything with the craft folder in /public_html was working fine), moved that copy back under the public root. Switched the directory call in index.php and it works now. Go figure, it was permissions after all.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.