1

I've tried installing a plugin to my Craft 3 local installation. I ran this from the command line in my project root:

composer require boboldehampsink/import but, this error was returned

craft/plugins/import/ does not exist and could not be created.

Thanks if anyone can help.

1

You are trying to install a Craft 2.x plugin, which you can see, among other things, by looking at its composer.json. Craft 3 plugins will always have a "extra property with a "handle" defined.

"extra": {
    "handle": "plugin-handle",
}

The currently latest release of the Import plugin is v0.8.33, and is not compatible with Craft 3:
https://github.com/boboldehampsink/import/blob/0.8.33/composer.json

Until the plugin store goes live, most plugin developers note their compatible plugins in this list:
https://github.com/craftcms/plugins

|improve this answer|||||
  • Thanks, I thought I could use the craft3 branch, but looks like that's not going to work. – jeremyhoover Aug 20 '17 at 3:49
  • Craft 3 alpha and beta releases had a couple of breaking changes so far, and it looks like that branch didn’t get updated for months. – carlcs Aug 20 '17 at 10:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.