1

I use MAMP Pro for a few years in combination with Craft CMS, but since the new upgrade to version 4 I cannot upload JPGs anymore. Dit anybody had the same issue and how to fix this?

In the PHP7.0.20.ini there's a line says:

MAMP_Imagick_MAMPextension=imagick.so

And these are the settings for resource limits:

max_execution_time = 240
max_input_time = 240
memory_limit = 1024M 
upload_max_filesize = 32M

But it's different from earlier versions, so it looks like ImageMagick is loaded?

Thanks in advance.

Cheers, Martijn

  • 1
    Is there anything showing in the Craft logs under Storage > Runtime? Image upload problems wouldn't be related to GD or Imagick specifically as they aren't responsible for the upload, it's more likely a permissions problem. I have a number of different environments, MAMP being one of them and have uploads working correctly. – Chris Southam Aug 15 '17 at 9:21
  • 1
    No, when I try to upload a JPG the progress bar fills up and freezes. Nothing appear in the log. And PNG files can be uploaded right away. – Martijn La Feber Aug 15 '17 at 13:02
  • When I check the logs in MAMP I see this error in the appache_error.log: [Tue Aug 15 15:00:56 2017] [error] [client ::1] FastCGI: incomplete headers (0 bytes) received from server "/Applications/MAMP/fcgi-bin/php7.0.20.fcgi", referer: craftcmsdeluxe.dev/admin/assets – Martijn La Feber Aug 15 '17 at 13:13
5

I found the answer: in the main window of MAMP Pro there's a sidebar with a sub heading Languages > PHP. When you click that and check the option under Extensions: Imagick / ImageMagick, all my problems disappear and I can upload JPG and PNG.

  • Haha. Unreal that is was this easy! Thanks a lot my man. – Dan Zuzevich Mar 5 '18 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.