0

I get "Service Unavailable" when I go to my (hosted, not local) test site.

It had been working just fine until I decided to swap databases today.

I deleted the old database and replaced it with the new database. I kept the database name the same. I changed the username and password in cPanel and then duplicated those changes in my craft/db.php file... But no dice... I get the nice little warning:

Service Unavailable

Our site is temporarily unavailable. Please try again later.

I have checked more than once, the path, db name, username and password all check out. Any suggestions? ...other than start over

5

Others have said what the problem is, but in the interest of clarity for future readers...

Cause: The database is expecting a newer version of Craft's filesystem than you have.

Solution: Replace the /app folder with one from a fresh Craft download and visit your admin trigger URL

2

Based on your comments to @benface, I believe your database is using a version of Craft ahead of your files.

1

Try going to /admin, you should get a clearer error message.

  • No joy. I just get the following Oops! Craft CMS does not support backtracking to this version. Please upload Craft CMS 2.6.2988 or later. ...I should note that I had changed my admin page to a different name, this is the error I get when I go to the renamed admin page. – Hellyar Aug 8 '17 at 18:42
  • I believe that means your database is using a version of Craft ahead of your files. – Stephen Callender Aug 8 '17 at 18:44
  • Yep, that is what I forgot to check. – Hellyar Aug 8 '17 at 18:48
  • @Stephen Callender had it correct... I forgot to check if the Craft versions matched. They did not. – Hellyar Aug 8 '17 at 19:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.