1

Due to problems I had with Craft 3 Beta 23 I switched back to version Beta 22 (I did this a couple of times)

I do this by importing an sql dump of beta 22 and by directly requesting Beta 22 via composer.

The strange thing: Craft forgets about Plugins it had installed. They simply do not appear anymore in the plugins list, although they are installed via composer and nothing changed in them.

I cleared storage/runtime and I also cleared the DB cache via utilities, that does not help.

Any hints why Craft does not show the plugins anymore in the list? Is there another cache?

3

Craft 3 knows about available plugins via the vendor/craftcms/plugins.php file, which stores info about all Composer packages that were installed with type: craft-plugin in composer.json.

If that file doesn’t exist or is just returning an empty array, then make sure that the craftcms/plugin-installer Composer package is installed, and try re-requiring each of your Craft plugins. As they are (re-)installed, they should get added to plugins.php.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.