4

I'm experiencing a problem where none of the plugins (2 captchas, and a random bookworm plugin) are showing up in my admin panel.

Folders are lowercase.

I've also checked permissions; folders are at 755. The corresponding file is at 644.

I have the Pixel & Tonic Contact Form plus the RetconHTML plugins currently in there, so I know I've successfully uploaded plugins before. Just not sure what's going on.

Thoughts?

-edit-

The two plugins I'm currently having problems with are bookworm and recaptcha, not anything I've specifically developed.

Here's a screenshot of my plugins directory: enter image description here

2
  • Can you edit the question and provide links to the 2 captcha and bookworm plugins? Or are these ones you've custom developed?
    – Brad Bell
    Commented Jul 28, 2017 at 22:47
  • Weird... looks correct from the screenshot.
    – Brad Bell
    Commented Jul 31, 2017 at 0:41

2 Answers 2

6

Probably the name of the folder isn't the plugin handle. Check inside the plugin's folder to see if the actual plugin folder is inside there. For instance:

forge@nys-production ~/nystudio107.com/craft/plugins (master) $ tree -L 1 craft-typogrify/
craft-typogrify/
├── readme.md
└── typogrify

In this case, when the plugin is downloaded or cloned, the name of the folder is craft-typogrify but the actual plugin folder is inside of this folder, and is named as a lowercase version of the plugin handle: typogrify.

This is what needs to be directly in the craft/plugins folder for Craft to see it.

1
  • I believe I have them correctly named. That seemed to be the most common reason for plugins not showing, so I checked that first. I've attached a screenshot to the original question - perhaps you'll see something I've missed.
    – Shad
    Commented Jul 30, 2017 at 15:09
5

I'm an idiot.

In the Settings area, I was expecting the plugin to show up in the Plugin section after uploading. Don't know why, but noticed last night that under the System section, there was a plugin option there. Once I went in there, and actually installed the plugin, it showed up under the Plugins section.

sheesh

1
  • Thanks man, your answer helped me! I installed my plugins via composer. So I had to go to the plugins page to install the plugins before they showed up. Commented Feb 6, 2019 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.