0

I have tried to configure email as an SMTP client for a Google Mail server. When I click test I get a generic "There was an error testing your email settings", but no further info in Craft log files. The error displays almost instantly, so it does not seem like a connection issue, e.g. password / username error.

Craft is latest version and site is hosted with Arcustech.

4
  • Can you post your config (obfuscating your credentials of course)? Commented Jun 20, 2017 at 17:04
  • 1
    There should be an error getting logged in craft/storage/runtime/logs as well.
    – Brad Bell
    Commented Jun 20, 2017 at 17:26
  • As I said in the post, no errors show up in the logs
    – Roi Agneta
    Commented Jun 21, 2017 at 18:02
  • Config settings: protocol:smtp hostname:smtp.google.com port:465 use SMTP authentication Username:my email address Password:my password SMTP Secure Transport Type: SSL Note that these settings are recommended by Google and the exact same settings work fine in my desktop email client
    – Roi Agneta
    Commented Jun 21, 2017 at 18:07

1 Answer 1

2

Google considers SMTP to be an "insecure" protocol when connecting to their servers. You have to explicitly go into your account settings as described here and enable access for these "insecure" requests.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.