1

I've got a problem with some tasks. Craft tells me 'Deleting Stale Template Caches Failed' multiple times.

When I look in the Deprecated Warnings, it tells me two things:

  • Ordering tags by ‘name’ has been deprecated. Order by ‘title’ instead.
  • The Tag ‘name’ property has been deprecated. Use ‘title’ instead.

I don't know if this will fix my task errors, but it would be nice to solve this problem as well.

This warning is strange to me because I don't ordering my tags by name, I order them by title:

 <section class="overview-search__filter">
    <div class="overview-search__filter-item activity">
        <select class="multiselect multiselect-activitytype" multiple="multiple" data-search-filter="activityType" name="activityType">
            {% for tag in tags.order('title') %}
                {% set selected = (filters['activityType'] is defined and tag.title in filters['activityType']) ? 'selected': ''  %}
                <option value="{{ tag.title }}" {{ selected }}>{{ tag.title }}</option>
            {% endfor %}
        </select>
    </div>
    <div class="overview-search__filter-item activity">
        <select class="multiselect multiselect-place" multiple="multiple" data-search-filter="activityLocation" name="activityLocation">
            {% for location in locations.order('title') %}
                {% set selected = (filters['activityLocation'] is defined and location.title in filters['activityLocation']) ? 'selected': '' %}
                <option value="{{ location.title }}" {{ selected }}>{{ location.title }}</option>
            {% endfor %}
        </select>
    </div>
</section>

Any ideas?

1

First problem sounds like it might be a permissions issue. Have you made sure you've got the right permissions on the /craft/storage folder? More details can be found here in the docs:

Step 2: Set the permissions

Possibly related to the above, did you originally use name and then updated it to title at a later time? One possible reason for your deprecated messages might be the template is cached with the old name value. Sorting out the above should at least enable you to clear the cache, using the Clear caches button in the Settings.

| improve this answer | |
  • Thanks for the reply! I fixed the first problem, it was a memory issue because I was using too many 'cache' blocks. The problem related to the title and filter is still not solved. In the past I did used 'name'. After I changed it to 'title' I deleted my cache, but the problem still occurs. I've deleting my cache a couple times but without succes. I also deleted my 'cache' directory in my storage. – Mr. Sam Jun 20 '17 at 13:02
  • No worries. If you visit the page in question now, do you still get deprecation errors? Only these may just be left over from when you originally had name in there. – Steve Holland Jun 20 '17 at 13:16
  • I just noticed you've got an array in there called filters, how is that getting populated? Only I don't see it in your example code. If that's in another file maybe you've accidentally left a reference to name in there? – Steve Holland Jun 20 '17 at 13:19
  • The population of filters has no ref to name. I find it strange that the deprecation errors could be left over from the past. Is there a way to delete this 'cached' error? – Mr. Sam Jun 21 '17 at 10:17
  • When I said they could be left over, I just meant unless you clear the deprecation errors, they will remain in the list. Take a look at the errors in the Control Panel /admin/utils/deprecationerrors. If the date in the last occurrence column is in the past then it's no longer a problem you need to worry about. If that is the case then you can just clear the deprecation errors individually by clicking the little Delete button on the right. Or if you want to get rid of all of them just click the Clear All button. – Steve Holland Jun 21 '17 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.