1

I am having issues running CraftCMS in a vagrant environment.

For reference:
I am using ubuntu 17.04
Vagrant version 1.9.5
ubuntu/xenial64 (virtualbox, 20170525.0.0)
Relevant initial provisioning here

After the vagrant box is booted up I wget the lastest CraftCMS files.
I then run chmod -R 777 /craft/app/ (+/config/ /storage/)

From that point on I would normally be able to complete the installation but instead I am met with a RuntimeException (paste here, screenshot here)

I've tried setting the permissions inside and outside of the environment. I have also tried changing ownership to www-data. And even put the user in the www-data group.

I'm pretty baffled, as I have no problems running my craft install on my production servers. Any help would be appreciated.

1

The article Local Development with Vagrant / Homestead I wrote is about Homestead (which is great), but much of it applies to Vagrant in general as well.

Included in it are some performance tips, as well as how to solve the filesystem permissions with vagrant-bindfs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy