1

I tried to add a Category Select field into a Neoblock but when i first saved the entry I received the following error:

Internal Server Error

Could not resolve the subpath “{slug}”.

I removed the Neo Block with the Category Select but the error persists.

Any ideas?

  • Do you have {slug} set for any of the settings in the fields inside of Neo? – Brad Bell May 13 '17 at 22:46
  • Yes, @BradBell, i have a field using Categories to filter entries via the Categories fieldtype in a neo subblock. That field is saved and visitors can see final page, but no more changes can be saved. It began when I tried to use the same Category for a second, different filter on this page. Reverting DD, template files have not fixed the issue. Even trying to remove the data associated with the original usage of the Category has not helped (because i can't save it). Thank you. !screenshot. – isral May 15 '17 at 13:03
  • Update: recreating the page 1 block at a time, it seems this issue is also happening when i try to add an Asset. – isral May 15 '17 at 13:54
  • @BradBell Hi, will changing {slug} to {owner.slug} affect data previously entered while using {slug}? – isral May 15 '17 at 16:42
  • Currently using v 2.6.2980 – isral May 15 '17 at 16:43
1

i removed {slug} altogether from an Asset field definition.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.