4

I'm trying to install Craft for the first time, I've used Ben Croker's requirements check and everything passes, and I'm pretty sure everything else is set up properly, but when I access domain.com/admin to run the install, I just get a blank screen - no errors, warnings or messages.

I've tried installing in a subdomain (my preference) as well as in the root, with the craft dir both above and below the root, but get the same result no matter what the config.

I've checked the logs (craft.log) and it gets this far (see below). There is no phperrors.log file. Does anyone have any ideas where I should check next?

2014/08/20 11:49:16 [info] [application] $_GET=array (
  'p' => 'admin',
)

$_SERVER=array (
  'DOCUMENT_ROOT' => '/xxx/xxx/public_html',
  'GATEWAY_INTERFACE' => 'CGI/1.1',
  'HTTP_ACCEPT' => 'text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8',
  'HTTP_ACCEPT_ENCODING' => 'gzip,deflate,sdch',
  'HTTP_ACCEPT_LANGUAGE' => 'en-US,en;q=0.8,es;q=0.6,fr;q=0.4,it;q=0.2,ja;q=0.2,pl;q=0.2,ru;q=0.2',
  'HTTP_HOST' => 'xxx.xx.xx',
  'HTTP_PROXY_CONNECTION' => 'keep-alive',
  'HTTP_USER_AGENT' => 'Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.143 Safari/537.36',
  'PATH' => '/bin:/usr/bin',
  'QUERY_STRING' => 'p=admin',
  'REDIRECT_QUERY_STRING' => 'p=admin',
  'REDIRECT_STATUS' => '200',
  'REDIRECT_UNIQUE_ID' => 'U-SLOlmRTRcABtAqnnkAAAAx',
  'REDIRECT_URL' => '/admin',
  'REMOTE_ADDR' => 'xx.xx.xx.xx',
  'REMOTE_PORT' => '62291',
  'REQUEST_METHOD' => 'GET',
  'REQUEST_URI' => '/admin',
  'SCRIPT_FILENAME' => '/xxx/xxx/public_html/index.php',
  'SCRIPT_NAME' => '/index.php',
  'SERVER_ADDR' => 'xx.xx.xx.xx',
  'SERVER_ADMIN' => 'xxxxx',
  'SERVER_NAME' => 'xxxxxx',
  'SERVER_PORT' => '80',
  'SERVER_PROTOCOL' => 'HTTP/1.1',
  'SERVER_SIGNATURE' => '',
  'SERVER_SOFTWARE' => 'Apache',
  'UNIQUE_ID' => 'U-SLOlmRTRcABtAqnnkAAAAx',
  'PHP_SELF' => '/index.php',
  'REQUEST_TIME_FLOAT' => 1408535356.3350970745086669921875,
  'REQUEST_TIME' => 1408535356,
)
2014/08/20 11:49:16 [trace] [system.CModule] Loading "db" application component
in /xxx/xxx/xxx/craft/app/etc/web/WebApp.php (642)
in /xxx/xxx/xxx/craft/app/etc/behaviors/AppBehavior.php (69)
in /xxx/xxx/xxx/craft/app/etc/web/WebApp.php (799)
3

I'm documenting this here in case it helps someone else. My white screen during installation was caused by a missing comma between array items in my general.php and db.php config files. Once I added it, the install page loaded correctly.

enter image description here

2

Thanks for the responses.

The problem has somehow gone away, so I can only assume it was a local error with my setup. I deleted everything, including the database etc, and installed from scratch, and now everything works.

1

What happens if you try the alternate URLs noted here? http://buildwithcraft.com/docs/installing#step-5-run-the-installer

If it's a pure white screen, that sounds like an Apache error. Try checking Apache's error log files for any relevant errors.

1

This happened with my install too. It turns out that the session.save_path was not defined in php.ini. As soon as I set that to a suitable location with read/write permissions, Craft came to life.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.