1

I set up my first Craft site on my shared hosting and I can't get it to work for the life of me. Whatever I do, I run into a 404 error. .htaccess is there and named correctly, craft folder is one level up as it should be. What I noticed is that it briefly works after setting the correct permissions on the craft files and folders. A couple of clicks later the permissions seem to reset again back to 755. I haven't had this problem with my hosting before, so I am unsure if this is a craft problem? Or if the permissions even are the cause?

Edit: It doesn't appear to be a permission problem after all. Filezilla shows 755, although the permissions are set to 744. So now I'm at a total loss what the issue could be.... I can't even complete the installation because it stops working beforehand. Tried several times more and got it installed. Just before it goes wrong again, I can see that it doesn't load the site properly, e.g. the login screen looks weird. Has anyone seen this before?

enter image description here

1

Do you happen to be on Dreamhost? I had a site there recently where they changed my permissions "for my own good".

  • No, it's a German hosting company and it doesn't seem to be a permission problem after all. – koni666 May 1 '17 at 15:26
1

Could be Apache's mod_security module being overzealous. mod_security tends to throw down its gauntlet especially when it sees lots of files being created or thrown around (for example when installing something). The module is commonly used on shared providers to mitigate common hacking attempts.

You might want throw this in your .htaccesss file and see what happens.

<IfModule mod_security.c>
  SecFilterEngine Off
  SecFilterScanPOST Off
</IfModule>

This effectively turns off mod_security. You may also have to ping your host and ask them if it's on and to turn it off manually for you since some hosts don't allow it to be disabled in .htaccess.

I'd hazard a guess and say Craft may not be completely installed either, especially if it is mod_security.

  • Thanks for the hint, I am going to check with my hoster and report back. The snippet didn't help yet but it seems more and more likely that it is indeed a hosting problem and not a Craft problem. – koni666 May 2 '17 at 5:13
  • It was a problem at my hoster after all. According to them there was a rogue process, so now that they killed the process and rebooted the server, it works fine! – koni666 May 2 '17 at 8:36
  • Glad you got to the bottom of that. – John Morton May 2 '17 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.