1

I downloaded and installed Craft Personal on my computer and choose /websitetest/ as my website name. I used MAMP and phpMyAdmin to create a database.


Still to access my website the url is http://localhost:8888/ and when I try to access http://localhost/websitetest/ I get the following error message: Forbidden You don't have permission to access /websitetest/ on this server.


Moreover in my index.html file, when I call for an URL entry:

href="{{ entry.url }}"

by default it redirects towards /websitetest/_entry , which displays me the same error message, while localhost:8888/_entry works when I test it manually!


Some ideas where can this come from?

Thanks!

  • If you want to get rid of the :8888 port number, you're going to have to tell MAMP about it. I'm assuming there is some MAMP port settings for your site. If a domain doesn't have a port, it's assumed to be port 80, so try changing it to that. – Brad Bell Apr 29 '17 at 14:31
2

Unless instructed otherwise, MAMP uses port 8888. You can tell it to use the "default" ports, which will mean the site gets served over port 80, and your URLs no longer contain :8888.

As for the other issue, it sounds like you haven't set up your site's document root correctly. Either way, it's a MAMP configuration issue, not a Craft issue.

| improve this answer | |
  • Thanks Stephen and Brad for your answers! Indeed I can change the port 8888 to the default port. I am going to try to set up my site's document root again, do you know what could cause that in the configuration? Could it be an issue with the database also/ – Lisonc May 1 '17 at 17:15
  • Problem solved! I don't know exactly what I did wrong the last time but I started the set up again and this time everything works perfectly. Thanks again! – Lisonc May 1 '17 at 22:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.