0

I am developing my Craft site locally with MAMP. Today when starting my site on localhost, I got this error:

CDbCommand failed to execute the SQL statement: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'craft_mysite.craft_info' doesn't exist

I have replaced the /app folder with a fresh copy, but it didn't help.

Also, I can no longer log into my site: When navigating to my login page, I get the same error as mentioned above.

I have a recent database backup in /craft/storage/backups. Is there a way to get my site up and running again?

3
  • Sorry for asking the obvious, but if you connect to your craft_mysite database, does the craft_info table exist?
    – Brad Bell
    Apr 3 '17 at 18:07
  • Hi Brad. I checked inside my phpMyAdmin and I haven't found any such table.
    – Patrick
    Apr 3 '17 at 21:23
  • Well, there's the problem. :) Have you been through the Craft installer yet? Do any other tables exist in the craft_mysite database?
    – Brad Bell
    Apr 3 '17 at 21:37
1

I solved the problem by setting up a new installation and then importing my backup database into that new installation. Now everything is there again and works.

I must admit I haven't found the reason why this problem occurred. But the solution was ultimately quick and easy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.