1

OK, setting up a production server (not live yet) and I am encountering a strange issue that I have not seen previously.

Issue: Installed Craft on an Ubuntu 16.10 LAMP server. When all commands for installing were completed, I tested my site with its IP address to make sure everything worked and I got the following: enter image description here

Then when I got to 192.168.5.254/public/index.php/admin/install -- which has worked on the two test servers I have built previously -- I get this: enter image description here

An to make sure that I have tried another method of gaining access to the installer, I went here 192.168.5.254/admin which redirected to 192.168.5.254/admin/login, I get this: enter image description here

Clearly Craft is working as these are not Apache 404's; however I never got the install screen at all. Just the homepage and login screen. Did I miss or mess something up during this specific install?

As usual, if you need additional information, let me know I will post it in here for visual use. Thank you very much for your assistance!

2
  • 3
    The install process is only done when you set up the database the first time. If you've moved the database to the production environment, craft is already "installed", and /admin/install will return a 404 not found. To me it looks like everything is working as it should, what makes you think that you need to run the installation process? Commented Mar 25, 2017 at 11:38
  • That makes a lot of sense and thank you for the clarification here; still a neophyte to Craft, I got all the files from the Dev who has been working on this and thought it was a 1-1 install of a vanilla site. Was not thinking about the db being previously create in staging. Thank you very much! Commented Mar 27, 2017 at 15:45

1 Answer 1

1

As André pointed out, you only need to run the installer if you need Craft to create all of the necessary tables in a blank database.

If you've dumped your database from dev/staging and imported it into production, there is no need to run the installer, because the tables are already there.

If Craft sees someone try to load the installer on a site that already has a populated database like you have, it will return a 404.

1
  • Thank you for the clarification on this as well. Was not thinking that since the db was created in staging, I would not need the installer for the production server. Thank you for the clarification! Commented Mar 27, 2017 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.