1

I have installed the oAuth and Social Poster plugins. Created OAuth 2 app via Twitter API Manager. Went to Keys and Access Token and copied Consumer API Key and API Secret and pasted into Client Id and Client Secret (OAuth). When I went to Social Poster plugin / Accounts / Twitter and hit the Connect button. It redirects /sample.com.au/index.php/admin/actions/socialPoster/accounts/connect?handle=twitter to sample.com.au/index.php/admin/actions/oauth/connect?provider=twitter. It appear to be blank and no warning.

I followed the guidelines from two plugin's homegpage and no success getting it to work.

I am not sure if my other plugins are interfering with the process or because I moved Craft outside of domain for security measure.

Could anyone advice me how to setup the plugin properly so I can start sending entries to Twitter.

2
  • If you enable devMode do you get an error instead of a blank page?
    – Brad Bell
    Mar 22 '17 at 18:19
  • Hi, I have turn on devMode and now I can see the error. Fatal error: Call to undefined function GuzzleHttp\Handler\curl_reset() in /home/zeze3574/public_html/craft/plugins/oauth/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php on line 78. What does that error mean? Mar 23 '17 at 8:48
1

Based on the error you're getting:

 Fatal error: Call to undefined function GuzzleHttp\Handler\curl_reset() in /home/.../public_html/craft/plugins/oauth/vendor/guzzle‌​http/guzzle/src/Hand‌​ler/CurlFactory.php on line 78

I'd guess that your cURL installation goes have curl_reset available to it, for whatever reason. Maybe your host has it in your php.ini file's disable_functions setting.

2
  • Thank Brad, I checked my web host and yes it was not activate which I have request to be activate. Now I am recieving a new error. Received HTTP status code [401] with message "{"errors":[{"code":32,"message":"Could not authenticate you."}]}" when getting temporary credentials. Does that mean the id and sercet code is inncorrect? I basically copied and paste Owner ID and Consumer Secret from Twitter App Mar 24 '17 at 0:50
  • Yeah, not familiar with the plugins, but the error message sounds like it's some credential problem.
    – Brad Bell
    Mar 24 '17 at 3:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.