2

I am editing an already existing field in Craft. When I go to save, I get an error message that says "Couldn't Save Field", and the block type is highlighted in red. The field type is a Matrix that contains a rich text field, a Link It field, and an image field.

I am on Craft CMS 2.6.2949.

Any ideas on what could be causing this error?


Edit: Additional Info

Below is a screenshot of my Matrix field + child fields. I get the error only when I use one of our entry types as the Link Type.

enter image description here

  • 1
    If you click the red block type, find the red field. There should be an error message there. – Lindsey D Mar 21 '17 at 19:54
  • Thanks @LindseyD - when I click the red block type, there are no fields that are being highlighted in red. Further update: When I try to create a new Matrix field, I am able to save until I add a Link It field type to the Matrix. When I add a Link It field, it gives me the error again ("Couldn't Save Field"). – jennetcetera Mar 21 '17 at 20:14
  • What is the handle for your Link It field? Certain handles (like "link" or "url") are restricted words and can't be used. – Lindsey D Mar 21 '17 at 20:16
  • I've tried several things: "clientwebsite", "link", "test"... – jennetcetera Mar 21 '17 at 20:19
  • 1
    Possibly a Link It bug? There's a vaguely similar sounding issue already created here: github.com/fruitstudios/LinkIt/issues/35 – Brad Bell Mar 21 '17 at 20:58
1

It's entirely possible it's a Link It bug. There is a vaguely similar sounding issue already created here: https://github.com/fruitstudios/LinkIt/issues/35

| improve this answer | |
  • Thank you! We've concluded that it is most likely a Link It bug, and we are transitioning out of using this field type as it is preventing us from making changes. – jennetcetera Mar 22 '17 at 0:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.