2

I am trying to import from Wordpress, so originally installed the Import plugin which worked but I needed xml not csv. So I uninstalled that and installed another, but now no matter what plugin I try to install, nothing shows up!

Any ideas? I tried resetting cache etc.

Update: Adding more details.

I've tried to install multiple plugins since the original one, the current plugin that I have in the plugins folder is 'craftimport-master' with all the correct files inside it.

The plugins page just says "There are no available plugins." with no errors. I've tried running Clear Caches and Rebuild Search Indexes, just in case it worked.

I also tried updating to Pro (using craft.dev) but that didn't change it either.

Here is the current file structure:

file structure

Oh and there was an error when I uninstalled the first plugin but it redirected me almost instantly so I don't know what it said.

  • possible duplicate of Two Plugins not showing in CP after pushing to staging server – Victor In Aug 14 '14 at 11:00
  • Have you tried clearing the cache in the control panel under Settings > Clear Caches? – Josh Angell Aug 14 '14 at 11:35
  • Yes I've cleared the cache from settings (that's what I was referring to in the OP) and I don't think it is a duplicate because the plugins are all lowercase and I'm not on production. – Shane Hudson Aug 14 '14 at 11:38
  • Hi Shane, would you mind posting a screenshot of your directory structure? At least for /craft/plugins ... it would help for us to peek at what's in there. – Lindsey D Aug 14 '14 at 14:30
  • 1
    I've updated the post with all the details I can think of. – Shane Hudson Aug 15 '14 at 10:31
6

It looks like the folder name of your plugin is wrong. Change it to just say craftimport.

The folder name should be the same as the "Whatever" part of the WhateverPlugin.php file sitting in the plugin's root folder. Except that the folder name should always be all lowercase. That's important, because some systems are case-sensitive while others are not... The only way to be certain your plugins will be detected is to use a lowercase folder name. (see this thread...)

  • I had that to begin with, and have tried again but it still doesn't show any (even after a clear cache). – Shane Hudson Aug 15 '14 at 11:02
  • 1
    Check the permissions of your craftimport folder (and its contained files)... In rare instances, you could end up with permissions which don't allow you to "execute" those files/folders. – Lindsey D Aug 15 '14 at 17:46
  • 2
    lowercase works. – Hasco Ulijn Oct 26 '15 at 8:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.