2

So we're trying to set-up a site to run both HTTP & HTTPs version in parallel for SEO auditing before making the full switch to HTTPs. We followed Ben's answer on this SE question to make it work: https://craftcms.stackexchange.com/a/4734/57.

The behavior we're seeing after implementing Ben's recommendation are that we can access both the http and https version of each page but a click on any link in the site populated by Craft templates (nav, blog overview page linking to other entries, etc.) takes us to the HTTP version of the page. So for example, if you're on https://example.com, a click on a nav link takes you to http://example.com/click rather than https://example.com/click. However, if we have a root relative link that was added manually through the control panel, that takes you to a version of the page consistent with the protocol of the current page. Basically, Craft is treating all links as if they're HTTP, even if you're on the secure version of the site.

We would like the site to function where if you're on the HTTPs version, a click on any link keeps you on the HTTPs version. Same goes for if you're on the HTTP version, any link click takes you to another HTTP page.

Is there a way to configure Craft to make that happen?

Here are the contents of our craft/config/general.php file:

<?php

/**
 * General Configuration
 *
 * All of your system's general configuration settings go in here.
 * You can see a list of the default settings in craft/app/etc/config/defaults/general.php
 */

// SEE http://buildwithcraft.com/docs/multi-environment-configs for info


// Ensure our urls have the right scheme
define('URI_SCHEME',  ( isset($_SERVER['HTTPS'] ) && $_SERVER['HTTPS'] == "on" ) ? "https://" : "http://" );

// The site url
define('SITE_URL',    URI_SCHEME . $_SERVER['SERVER_NAME'] . '/');

// The site basepath
define('BASEPATH',    realpath(CRAFT_BASE_PATH . '/../') . '/');

return array(

  // DEFAULT
  '*' => array(
    //'isSystemOn' => false,
    'omitScriptNameInUrls' => true,
    'cpTrigger' => 'discover',
    'addTrailingSlashesToUrls' => true,
    'siteUrl' => SITE_URL,
    //'devMode' => (preg_match('/dev|xip|staging/', $_SERVER['HTTP_HOST']) ? true : false),
    'devMode' => false,
    'pardotUserName' => "FILLER TEXT",
    'pardotPassword' => "FILLER TEXT",
    'pardotUserKey' => "FILLER TEXT",
    //'backupDbOnUpdate' => false,
    'generateTransformsBeforePageLoad' => true,
    // 'cacheDuration' => false,
    'defaultImageQuality' => 90,
    'caseListPagination' => 6,
  ),
  // Example dev
  'example.dev' => array(
    'devMode' => true,
    'caseListPagination' => 2,
  ),

  'example.svn.dev' => array(
    'devMode' => true
  ),

  'local.example.com' => array(
    'devMode' => true,
    // 'enableTemplateCaching' => false // Only work on Craft 2.4 and later
  ),
  'environmentVariables' => array(
    'siteUrl' => SITE_URL,
    'basePath' => BASEPATH
  ),
);

Thanks!

3

What web server are you running? I ask because IIS will define the $_SERVER['https'] variable even if the site is being accessed via HTTP (it's value will be 'off') and Ben's answer is only checking if the $_SERVER['https'] variable is present.

One solution is to add a further check that $_SERVER['https'] == 'on'

Try updating this:

// Ensure our urls have the right scheme
define('URI_SCHEME',  ( isset($_SERVER['HTTPS'] ) ) ? "https://" : "http://" );

to this:

// Ensure our urls have the right scheme
define('URI_SCHEME',  ( isset($_SERVER['HTTPS'] ) && $_SERVER['HTTPS'] == "on" ) ? "https://" : "http://" );
  • Hey Tom, thanks so much for the response! I made the suggested update but am still seeing the same behavior. We're running ubuntu on Apache. – dpayne Feb 14 '17 at 22:18
  • Also, note that I updated the original question from the time of your response to highlight the different between links populated from the CMS and root relatives that are manually added, just in case it changes anything. – dpayne Feb 15 '17 at 2:19
  • It could be that your PHP config isn't outputting the $_SERVER variable, although it's unlikely. Lets start with the basics. Are you able to create a temporary file in your public directory and show the output of <?php die(var_dump(isset($_SERVER['HTTPS']))); for both HTTP and HTTPS. Remember to remove the file when you're done. Also, are you definitely setting the siteUrl config variable in config.php at the root of the array or under the '*' key? – Tom Feb 15 '17 at 15:19
  • Hey Tom, when I upload the temporary file and go to the HTTPs version, I see "bool(true)." When I go to the HTTP version, I see "bool(false)." As to the siteUrl config, setting it at the root of the array, yes. Thoughts? – dpayne Feb 15 '17 at 18:24
  • Can you post the contents of your craft/config/general.php? Probably overlooking something. – RitterKnight Feb 15 '17 at 19:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.