1

I'm having a strange issue where pages aren't loading on the staging site that were all working fine on the local.dev site.

I have a Section called Available Homes and in that section it has two Entry types called Available Homes and Plot which link to two entry templates, that are dynamically called from the main entry.html.twig template, which then links to the sub folder

/entry
  /availablehomes
    availablehomes.html.twig
    plot.html.twig
  default.html.twig

The sections Entry URL Format is as follows:

developments/{counties.first.slug}/{developments.first.slug}/available-homes

and nested entries get the following:

{parent.uri}/{slug}

If I change the template from entry in the control panel to different template then it loads.

This is the entry template code:

{% include [
  "entry/" ~ entry.section.handle ~ "/" ~ entry.type,
  "entry/default"
] %}

Can someone help please?

enter image description here

1

I'm guessing staging has a case sensitive file system and your local dev site doesn't.

i.e. the section handle in your screenshot is called availableHomes, but the template folder you're referencing is availablehomes.

| improve this answer | |
  • Amazing, that was it. Something so simple. Will be extra careful with the folder naming in future. Thanks – mention79 Feb 8 '17 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.