2

I'm setting up a Craft site on a Linode server has anyone had any experience with this? I'm struggling with which owner and user to set the var/www/html folder to with chown and what chmod settings to use on the craft folders. Currently Craft does not show the index page and can't find the admin folder which are all where they are supposed to be so it seems to be something to do with apache permissions. Just wondered if anyone could advise what these should be?

1

I assume you've seen https://www.linode.com/docs/websites/apache/apache-web-server-on-ubuntu-14-04?

Craft really isn't any different than any other PHP application in the way it needs to be setup to execute. The only extra thing that other apps might not require (because most PHP apps don't auto-update) is that Craft needs to be able to recursively write to its craft/app folder in order for that to work.

There's a handy script here: https://github.com/nystudio107/craft-scripts that can help automate the necessary permissions for your box, but you'll need still need to know what user:group Apache is running as for it to set things up properly.

  • Yeah cheers @bradbell I've used the linode docs but they don't really explain the owner/user set up on apache. They do say it uses the default web-data:web-data for php but setting these I still get an error say php can not write to the runtime folder unless I change it to 777 which isn't secure! – Lettie Feb 1 '17 at 20:07
  • You try using that craft-scripts script with the user:group set to web-data:web-data? – Brad Bell Feb 2 '17 at 6:33
  • Hi @bradbell I have now tried the scripts. They seem straight forward and worked in changing permissions but the site still does not work. I tried changing ownership to my local user but had the same write issues with php. Then tried changing both user and group to www-data and have an error service unavailable and now I can't change the owner back to my user so I can no longer ftp to the server! Command I'm using logged in as my user. sudo chown myUser:myUser /var/www/html/mysite.com/public_html but doing a ls -l shows the owner and group still as www-data. Any clues? – Lettie Feb 4 '17 at 15:29
  • Try contacting Linode support? I'm really not that familiar with how they're setup. – Brad Bell Feb 5 '17 at 0:29
  • Currently in a dialogue with Linode support. – Lettie Feb 7 '17 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.