1

Ok so this is an incredibly wierd one and I have no idea how to explain the problem in just one sentence so I just put the error message as the title.

So I am building a site with craft...in fact its basically complete. I was developing it in linux ubuntu but also using the vagrant homestead virtual machine to develop from so OS is kinda irrelevant.

Anyway...this is at work and they decided to be nice and get me a mac for work for christmas so I'm just basically trying to set up my working environment on the new computer.

So I set up homestead, pull everything from the git repositories, set up the databases and import everything...go to launch the site and I get the error message that is in the title and it highlights this line: $value=unserialize($value);

ok...interesting...after some googling i read something and decided to try and go into my config file and turn off developer mode...

When I go to a normal page it gives me this error: CDbCommand failed to execute the SQL statement: SQLSTATE[42000]: Syntax error or access violation: 1055 Expression #25 of SELECT list is not in GROUP BY clause and contains nonaggregated column 'db_name.structureelements.root' which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by

I did some research into this and tried to edit my my.cnf file to modify the sql_mode parameter also with no luck although i think the line I was given was not correct for the version of mysql that I have...perhaps this is where the issue is?

...and when I try to log into the back end aka /panel it gives me this:

Your server doesn’t meet the following requirements to run Craft CMS:

Mcrypt is required.

Please talk to your host/IT department about upgrading your server.

Ok...fair enough...maybe I need this mcrypt thing...the thing is I think it is already installed? It is listed in my phpinfo(); I have gone through the steps to install it (and yes I have restarted nginx and php....and mysql and still nothing...)

I really have no idea what the problem here is...the only thing that i can think is that my vagrant environment is different to the one I had in linux as I downloaded it more recently but I have no idea what setting/software version number/whatever somewhere is different that might be causing this?

Please feel free to ask for more info as I really am not sure what I am looking for here...I know that the vagrant environment is working as well as normal php is running (as I was able to run the phpinfo(); function succesfully.

The vagrant box is running php 7.1

Thanks in advance...

Matt

8

Update:

Craft 2.6.2957 added support for PHP 7.1


There's a lot going on here, but 1st thing is 1st.

The vagrant box is running PHP 7.1

Craft 2 (and the current latest version of the Yii framework - 1.1.17) are not yet compatible with PHP 7.1.

When the next Yii 1 release is out that addresses the framework compatibility issues, we'll get Craft 2 up and running on PHP 7.1.

Until then, you'll want to use PHP 7.0.x.

|improve this answer|||||
  • hi @brad-bell. I think there's still issues about PHP 7.1 because I have a trait with namespace Craft but my plugin is not reading the trait. You're suggestion to use PHP 7.0 for now resolved the issue. – Anya Dit Dec 31 '16 at 6:43
  • I think you are onto something here! I am going to try using an earlier version of homestead with PHP 7.0 and see how that goes...cheers! – Matthew Jonat Jan 4 '17 at 10:29
  • Same error again on the latest version of homestead running 7.1.5 with the latest version of Craft 2.6.2981 – andrew-caulfield Jun 2 '17 at 8:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.