I tried up update to the latest Craft, but assets are not loading and the process stops here.

I deleted the storage/runtime folder but I got no luck.

enter image description here

enter image description here

Log says:

2016/11/08 20:17:23 [error] [application] Tried to read the folder contents of /var/www/dev/craft/craft/storage/runtime/compiled_templates/, but could not.

It doesn't matter if I set it to 777 or correct user.

Even stranger is that dispite the error log, I get content created in the compiled_templates folder.

  • Are those 500 Internal Server Errors or something else? Anything useful being logged in your web server's error logs?
    – Brad Bell
    Commented Nov 8, 2016 at 21:32
  • Yes, 500 errors. Regular PHP error logging works, a syntax error gets logged, but not the Craft errors. No phperror in the Craft storage either. Commented Nov 8, 2016 at 22:17

1 Answer 1


I figured it out. It was super unexpected, after turning on errors finally, I got

 Fatal error: Class 'Craft\AppPathCacheDependency' not found in 

Then I realized that GIT didn't include that file, still not sure why, but now I know the cause.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.