1

Recently, anytime an update to Craft core or a plugin is attempted on my site that requires a database migration I get an Internal Server Error: Could not validate update handle. Does anyone know what handle Craft is talking about here? Looking for help debugging this issue. My guess is that somewhere in the midst of updates and rollbacks the database got out of sync with the source code. Just need to track down where this faulty handle is.

  • Is this just happening on auto-updates or manual? Both? – Brad Bell Nov 3 '16 at 21:55
  • Hey Brad. For craft core updates I use auto-update in local development and then push those changes up to dev and prod. I haven't had a problem with the migrations in local or staging, but production triggers the error when I try to start the migration. For plugins, it's a manual update that gets pushed up. So yes, both :( – Liam Scott Nov 4 '16 at 14:50
  • Any chance you've got a plugin installed that's listening for update events? – Brad Bell Nov 4 '16 at 18:47
  • Hmmm I'm not sure. Where would I look to check? – Liam Scott Nov 4 '16 at 20:11
  • If disabling all plugins isn't an option to test, then search for onBeginUpdate in the code and see if any plugins are referencing it. – Brad Bell Nov 4 '16 at 20:28
2

Looks like the issue had to do with my production environment being load-balanced. To avoid errors like these on load balanced sites, remember to set the validationKey and appId config keys in your general.php file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.