3

I am currently using the Standard JSON configuration. My config is below. I cannot get the image button to show up for my Body Field/Rich Text. This is the same configuration I've used on other CraftCMS sites without issue.

{
    buttons: ['html','formatting','bold','italic','unorderedlist','orderedlist','link','image','video'],
    plugins: ['fullscreen','video'],
    toolbarFixed: true
}
5

not sure if it matters but in my config I have buttons in quotes

"buttons": ["format","bold","italic","underline","lists","link","file","image","horizontalrule"],
  • Double quotes are the standard for JSON. – machour Oct 18 '19 at 8:07
1

You have to add this setting: imageUpload: true

Example:

    $('.editor').redactor({
        s3: 's3upload.php',
        fileUpload: true,
        imageUpload: true,

        buttons: ['format', 'bold', 'italic', 'underline', 'deleted',
                  'lists', 'outdent', 'indent',
                  'image', 'file', 'link', 'alignment', 'horizontalrule', 'source'],

        "plugins":["source"],
    });

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.