0

I'm installing Craft CMS on my domain which was formerly functional (previously used Wordpress). I removed all Wordpress files through FileZilla FTP and uploaded Craft files.

I put the /Craft folder in its entirety above the root.

I put the files in /Public in the Public_html folder.

I set up a new Database through my hosting provider and edited the db.php file with the credentials.

Now when I go to mydomain/admin I get an Apache 404: "Apache/2.4.10 (Debian) Server at chrislee.is Port 80"

I've triple checked the installation instructions given on the Craft site and can't see any mistakes. Any ideas about what may have gone wrong would be greatly appreciated!

  • Did you rename htaccess to .htaccess? Notice the period. If it works when you go to http://whatever/index.php?p=adminthen that's your problem. – RitterKnight Oct 14 '16 at 17:09
  • I did indeed :) The 404 error is present at /admin and /index.php?p=admin, and – Chris Oct 14 '16 at 17:14
  • 1
    I went to http://chrislee.is/index.php and your index.php doesn't exist either. Is your site's public "root" actually ``public_html`? Easiest way to tell is to drop in a static file like a gif or something and point your browser to it. – RitterKnight Oct 14 '16 at 19:25
  • I just tried this and this image doesn't work either - still gives a 404! I'll look into making public_html actually the root. Thanks for the heads up. – Chris Oct 15 '16 at 10:32
  • So I've managed to sort the root folder - if you go to chrislee.is/pic.jpg it now loads, but I'm still getting errors with the craft/ folder. It says "Could not find your craft/ folder. Please ensure that $craftPath is set correctly in /var/www/virtual/chrislee.is/htdocs/index.php" when visiting /admin, despite the fact that I've updated the location of craft/ in my index.php file. Any ideas? – Chris Oct 17 '16 at 11:50
1

How did you create the database? Did you use phpMyAdmin or did you create it manually, or using other tools?

I've had a similar 404 error last week (db was created with phpMyAdmin) then I created database with Sequel Pro and that resolve the problem.

  • I used the create database option on my hosting provider's website. I'll try with Sequel Pro and see if that helps - thanks for the suggestion! – Chris Oct 14 '16 at 16:25
  • OK I can't use it because I'm on Windows and I don't understand enough about MySQL to figure out an alternative. Looks like I'm in too deep here and I've barely even started..! – Chris Oct 14 '16 at 16:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.