I am running Craft locally using default/update Laravel Homestead/Vagrant box.

Image Transforms are returning the CP resources URL 404 error outlined in this related question: Image transforms returning cpresources url

  • I've confirmed that my host and vagrant box have the correct permissions
  • I've cleared cache and reindexed assets
  • I've tried the 'generateTransformsBeforePageLoad' => true,

I still receive the error: Failed to load resource: the server responded with a status of 404 (Not Found)

  • Are you calculating the dimensions on the fly, by chance? I ran into a similar problem, and eventually determined it was because I was trying to resize to a non-integer pixel value. E.g. if you set a transform like { width: image.width, height: (image.width / 2) } and the image is 555px wide, it will try to resize to 277.5px tall & freak out. Fix by changing to (image.width / 2)|round. Oct 27 '16 at 2:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.